Fork me on GitHub

Supported Bundlers

Currently these bundlers are supported:

ES2015 / ES6

The library is written using ES2015 loaders. A transpiler like Babel has to be used to build the module.

Here you find information on how to set it up in your Bundler:

  • Browserify: https://github.com/babel/babelify
  • Webpack: https://github.com/babel/babel-loader/blob/master/README.md
  • jspm: ES2015 Loaders are automatically installed with jspm.

Loading the Module

import angular from 'angular';
import angularHal from 'angular-hal';

angular
  .module('my-app', [
    '...',
    angularHal,
    '...'
  ])
;